Technorati Rank WordPress Plugin 2. bertsioa kaleratu da!

Lehenengo Technorati Rank Pluginaren hasieran, irteerako edukia birmoldatu dut hura egiteko CSS bultzatuta (behean pantaila-argazkia dago, nire webgunearen alboko barran elkarreragin dezakezu):

Technorati Rank WordPress Plugin 2. bertsioa

Hau nahiko zailagoa zen ekoizteko, baina irteera askoz ere politagoa da. Lehenik eta behin, ikasten aritu naizena baliatu dut Bittbox irudiaren irteerako botoietako bakoitza Illustrator-en egiteko.

Hurrengo urratsa estiloak erabiltzea zen norbait eraikitzeko irudiaren mapa ez dagoela benetan maparik ez! Polita da, egia esan. Dib atzeko plano orokorra ezar dezakezu eta ondoren "puntu beroak" sortu posizionamendu absolutua eta CSS erabiliz. Ikusi irteerako CSS.

Gainera, esteka bat gehitu diot Technorati berriari WTF orria eta gunearen RSS helbidea. Gustatuko zaizuelakoan! Lehen bertsioarekiko hobekuntza handia dela uste dut! Badago i plugina sustatzen duen beheko eskuineko esteka.

Uneko Technorati Rank WordPress Plugin 2.0.4 bertsioa

23 Comments

  1. 1
  2. 3

    Berrikienak eta handienak instalatzen saiatu naiz "letra" your zure jarraibideei jarraituz

    baina honako errore hau lortu dut

    Akats larria: ezin da existitu ez den klasea: simplexmlelement /home/winex4/public_html/wp-content/plugins/technorati-rank/technorati-rank.php 64 linean

    iradokizunik?

    • 4
      • 5

        horrek lehenik egiaztatzen irakatsiko dit .. itxuraz Lunarpages PHPren 4.4.4 exekutatzen ari da

        Asmatu beste bertsioa ikusi beharko dudala edo gogorra izan beharko dudala eta 5.0 bertsiora berritzen duten ala ez

        • 6

          Hala egingo dutela espero dut! Baina espero dut zure ostalariaren bertsio berritzea ere. PHP5ek errendimendu hobekuntza askoz hobeak dakartza, baita APIak kontsumitzeko tresna hobeak ere. Jumpline erabiltzen dut, esteka bat ikusiko duzu nire babesle zerrendan nire hasierako orrian. Uste dut Dotster-ek VDS ostatu ona duela azken eta handienarekin.

      • 7

        Doug,
        Arazo bera dut
        Ostalariari deitu nion eta esan zidaten nire zerbitzariak PHP 4 eta PHP 5 dituela, baina PHP 5 erabiliz fitxategia exekutatu nahi badut, scriptak .php5 fitxategiaren luzapena izan behar du.

        Beraz ... Fitxategiaren luzapenak aldatu ditut, eta wordpress-eko pluginetatik desagertzen da.

        Ideiarik?

  3. 10

    Plugin bikaina, estilo bikaina! Eskerrik asko Doug, eta lan bikaina. Inoiz ez nuen lehenengoaren berri izan, baina nire alboko barran laster doa.

    Benetan aberasgarria da nire Illustrator aholkuek zure botoiak egiten lagundu zaituztela ikustea !!!!!

    eskerrik asko berriro,

    ~ BittBox

    • 11

      Eskerrik asko, BittBox! Estiloari begi onak diodala uste dut, baina ez dirudi inoiz zuzentzen dudanik gehienetan. Zure laginak deskargatu eta disekzionatu ahal izatea da aldea. Ideia horiek gauzatzeko gai naiz orain. 🙂

      Nire blogeko goiburuari eta aurrekariei buruzko gogoeta batzuk egiten ari naiz.

  4. 12

    Beno, Doug, badirudi 2. bertsioaren pluginak gorroto nauela. Akats mezuak jasotzen ditut:

    Warning: fopen(/technorati-rank.html) [function.fopen]: failed to open stream: Permission denied in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 121
    Warning: fwrite(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 122
    Warning: fclose(): supplied argument is not a valid stream resource in /..../wp-content/plugins/technorati-rank/technorati-rank.php on line 123

    Akats mezuak gorabehera, nire Technorati maila ere erakusten du (~ 26.5k: D). Ez dut PHPri buruz behar bezain ongi ezagutzen fitxategi horren gainean zergatik negar egiten duen jakiteko.
    Interesgarria da, gure zerbitzarian, SuPHP erabiltzen dugu, beraz, guztia guk bezala funtzionatzen du (beraz, chmod eskakizunek ez dute munduan idazteko moduko fitxategirik behar, eta php script-ak ez dira exekutatuko chmod'-ak oso altuak badira, adibidez).

    Azpidomeinu honetako php guztiak php5 gisa exekutatzen dira.

    Ideia bat?

    • 13

      Baduzu wp-content / cache direktorioa Xial? WP-Cache-ren cache direktorio bera erabiltzea ideia ona izango zela pentsatu nuen. Atzera begiratuta, agian ez zen ideia ona izan! Lerro hori cache fitxategian idazteko da.

      • 14

        Zalantzarik gabe, Doug. WP-Cache nahiko denbora daramat. 🙂

        Kuriositate pixka bat ere banuen, honetaz zergatik kexatuko ote zen, beharrezko direktorioa baitut, baina asmatzen dut beste zerbait dela.

      • 15

        Gehitzeko informazio interesgarria:

        $ pwd
        /..../wp-content/cache
        $ ls -l tech*
        -rw-r--r-- 1 meeeeeeee meeeeeeee 1.1K Mar 12 11:47 technorati-rank.html

        Oraindik akatsak itzultzen ditu.

    • 16

      Besterik gabe, akats berdina edukitzea nahi duzu. Guneak php5 exekutatzen du eta botoiak bistaratzen du.
      121-123 lerroak iruzkintzen saiatu nintzen, eta entxufeak ondo funtzionatzen du. Zuzenean jarri al dezaket, edo linea horien faltak arazoak sortuko al ditu epe luzera?

  5. 17

    Aurreko akats berdinak jasotzen ari naiz, nire cache dirua zela ere pentsatu nuen, baina badut eta idazteko eskubideak zuzenak direla ziurtatu nuen.
    Alboko barran plugin-a erakutsiko du (sailkapenarekin), baina akats horien gainean.

    • 18

      Kaixo Richard,

      Egiaztatu al dezakezu PHP 5+ bertsioa eta CURL gaituta duzula? Hau egin dezakezu zure webgunean orri bat eraikiz <?php phpinfo(); ?> orrialde batean. Ondoren, ireki orri hori. Orriaren goialdean PHP bertsioa izango duzu eta CURL bilaketa egin dezakezu gaituta dagoela ziurtatzeko.

      Eskerrik asko!
      Doug

      • 19

        Beno, Doug, nire PHP bertsioa berriro egiaztatu nuen.
        PHP5 exekutatzen ari naiz, eta cURL hemen biltzen da (nire ostalariari egin ohi diodan hiru eskaeretako bat, PHPrako gauzak biltzeko).

        Beste guztiak ondo funtzionatzen du, baina ez dakit guztiz ziur zergatik ari den plugin hau itotzen, PHP-n konpilatutako cURL bertsioa ez bada behintzat (7.15.4-n gaude eta azken hori 7.16.1 dela dirudi). Hala ere, ez dut nahi nire ostalariari php5 berriro konpilatu nahi izatea horretarako, lagundu ahal badiot. <: 3

        • 20

          Asteburu honetan sakonago aztertuko dut. Gune gutxi batzuetan arazorik gabe funtzionatzen ari da. Beraz, 3 gauzetako bat da: 1. Cache, 2. cURL edo 3. PHP bertsioa.

          PHP 4 funtzionalitate zaharragoak erabil ditzaket XML atera eta aztertzeko, baina nahiko moteldu dezake. Asteburu honetan probatuko dut. Sarrera guztiak eskertzen ditut. "Houston, arazo bat dugu!".

  6. 21
  7. 22
  8. 23

    Eskaera dezente jaso ditut cache fitxategitik idaztean edo irakurtzean akatsak izan direla. Egia esan, cache fitxategia root direktoriora tiratzen eta tiratzen ari nintzen arazoa identifikatu nuen. 2.0.4 bertsioa aldatu dut pluginaren direktorioko cache azpidirektorio batean idazteko.

    Mesedez, jakinarazi iezadazu nola funtzionatzen duen! (Oraindik SimpleXML eta cURL behar ditu!)

Zer deritzozu?

Gune honek Akismet-ek spam erabiltzen du. Ikasi zure iruzkina nola prozesatu den.